Programmieren lernen mit Robot Karol: Unterschied zwischen den Versionen

Aus ComeniusWiki
Wechseln zu: Navigation, Suche
(Einseitige bedingte Anweisung)
(Parameter)
 
(18 dazwischenliegende Versionen von einem Benutzer werden nicht angezeigt)
Zeile 418: Zeile 418:
 
</pre>
 
</pre>
 
Wir übergeben dabei in der Klammer hinter dem Methodenaufruf die Anzahl der Wiederholungen. Neben ''Schritt'' und ''Hinlegen'' kann man auch ''Aufheben'' mit einem Parameterwert verwenden.
 
Wir übergeben dabei in der Klammer hinter dem Methodenaufruf die Anzahl der Wiederholungen. Neben ''Schritt'' und ''Hinlegen'' kann man auch ''Aufheben'' mit einem Parameterwert verwenden.
 +
 +
Weiterhin ist es mit Robot Karol (ab Version 3.0) möglich, den Methoden Hinlegen und MarkeSetzen eine Farbe (rot, gelb, blau und grün) zu übergeben.<br>
 +
Beispiel:
 +
<pre>
 +
Hinlegen(blau)
 +
MarkeSetzen(grün)
 +
</pre>
  
  
Zeile 656: Zeile 663:
 
   Schritt
 
   Schritt
 
   LinksDrehen
 
   LinksDrehen
 +
*wiederhole
 +
 +
MarkeSetzen
 +
</pre>
 +
 +
Noch etwas eleganter ist folgende Lösung. Sie berücksichtigt, dass man die Lösung für die erste Diagonale wiederverwenden kann.
 +
 +
<pre>
 +
Anweisung Diagonale
 +
  wiederhole 8 mal
 +
      MarkeSetzen
 +
      Schritt
 +
      Linksdrehen
 +
      Schritt
 +
      RechtsDrehen
 +
  *wiederhole
 +
*Anweisung
 +
 +
 +
Anweisung Bahn
 +
  wiederhole 8 mal
 +
      Schritt
 +
  *wiederhole
 +
*Anweisung
 +
 +
 +
Programm
 +
  Diagonale
 +
  MarkeSetzen
 +
  LinksDrehen
 +
  LinksDrehen
 +
  Bahn
 +
  LinksDrehen
 +
  Diagonale
 +
  MarkeSetzen
 +
  LinksDrehen
 +
*Programm
 +
</pre>
 +
</popup>
 +
 +
 +
5. In einer Welt der Größe 11x11 soll Karol folgendes Muster erzeugen. Verwende dabei eine selbstdefinierte Anweisung und eine Wiederholungsanweisung.
 +
 +
[[Datei:KarolStufe.JPG]]
 +
 +
<div style="margin-bottom:25px;">
 +
<popup name="Lösungsvorschlag">
 +
<pre>
 +
Anweisung Stufe
 +
MarkeSetzen
 +
Schritt
 +
MarkeSetzen
 +
Schritt
 +
*Anweisung
 +
 +
wiederhole 5 mal
 +
LinksDrehen
 +
Stufe
 +
RechtsDrehen
 +
Stufe
 
*wiederhole
 
*wiederhole
  
Zeile 777: Zeile 844:
 
*Programm
 
*Programm
 
</pre>
 
</pre>
 +
 
</popup>
 
</popup>
 
</div>
 
</div>
Zeile 874: Zeile 942:
 
<div style="margin-bottom:25px;">
 
<div style="margin-bottom:25px;">
 
<popup name="Lösungsvorschlag">
 
<popup name="Lösungsvorschlag">
 +
<pre>
 
wiederhole solange nichtIstWand
 
wiederhole solange nichtIstWand
 
   MarkeSetzen
 
   MarkeSetzen
Zeile 902: Zeile 971:
  
 
MarkeSetzen
 
MarkeSetzen
 +
</pre>
 +
 +
Alternative (bessere) Lösung
 +
 +
<pre>
 +
Anweisung Diagonale
 +
wiederhole solange nichtIstWand
 +
  MarkeSetzen
 +
  Schritt
 +
  Linksdrehen
 +
  Schritt
 +
  RechtsDrehen
 +
  MarkeSetzen
 +
*wiederhole
 +
*Anweisung
 +
 +
Diagonale
 +
LinksDrehen
 +
LinksDrehen
 +
 +
wiederhole solange nichtIstWand
 +
  Schritt
 +
*wiederhole
 +
 +
LinksDrehen
 +
Diagonale
 +
 +
</pre>
 
</popup>
 
</popup>
 
</div>
 
</div>
Zeile 1.038: Zeile 1.135:
  
 
a) Karol hat eine Reihe von Ziegelsteinen vor sich. Dort wo ein Stein liegt, soll er ihn wegnehmen, dort wo keiner liegt, soll er einen Stein hinlegen.<br>
 
a) Karol hat eine Reihe von Ziegelsteinen vor sich. Dort wo ein Stein liegt, soll er ihn wegnehmen, dort wo keiner liegt, soll er einen Stein hinlegen.<br>
b) Nun soll Karol das Ganze 4 mal wiederholen, wobei er jeweils an der Wand entlang zurückgehen und zu seinem Ausgangspunkt zurückkehren soll.
+
b) wie a), nur dass nun eine beliebige Zahl von Ziegeln übereinander liegen kann.<br>
 +
c) Nun soll Karol das Ganze 4 mal wiederholen, wobei er jeweils an der Wand entlang zurückgehen und zu seinem Ausgangspunkt zurückkehren soll.
  
 
<div style="margin-bottom:25px;">
 
<div style="margin-bottom:25px;">
Zeile 1.056: Zeile 1.154:
  
 
b)
 
b)
 +
<pre>
 +
wiederhole solange nichtIstWand
 +
wenn istZiegel dann
 +
wiederhole solange IstZiegel
 +
Aufheben
 +
*wiederhole
 +
Schritt
 +
sonst
 +
Hinlegen
 +
Schritt
 +
*wenn
 +
*wiederhole
 +
</pre>
 +
 +
c)
 
<pre>
 
<pre>
 
wiederhole 4 mal
 
wiederhole 4 mal
Zeile 1.070: Zeile 1.183:
 
*wiederhole
 
*wiederhole
  
 +
RechtsDrehen
 
RechtsDrehen
 
RechtsDrehen
 
wiederhole solange nichtIstMarke
 
wiederhole solange nichtIstMarke
Zeile 1.075: Zeile 1.189:
 
       Schritt
 
       Schritt
 
   sonst
 
   sonst
 +
      RechtsDrehen
 
       RechtsDrehen
 
       RechtsDrehen
 
   *wenn
 
   *wenn
 
*wiederhole
 
*wiederhole
  
 +
RechtsDrehen
 
RechtsDrehen
 
RechtsDrehen
 
MarkeLöschen
 
MarkeLöschen
Zeile 1.197: Zeile 1.313:
 
</popup>
 
</popup>
 
</div>
 
</div>
 
|width=20px|
 
|width=300px |
 
|}
 
 
  
  
Zeile 1.208: Zeile 1.319:
 
<div style="margin-bottom:25px;">
 
<div style="margin-bottom:25px;">
 
<popup name="Lösungsvorschlag">
 
<popup name="Lösungsvorschlag">
 +
<pre>
 +
MarkeSetzen
 +
wiederhole solange nichtIstWand
 +
Schritt
 +
MarkeSetzen
 +
wenn IstWand dann
 +
  wenn IstSüden dann
 +
    LinksDrehen
 +
    wenn IstWand dann
 +
      Beenden
 +
    *wenn
 +
    Schritt
 +
    LinksDrehen
 +
    MarkeSetzen
 +
  sonst
 +
    RechtsDrehen
 +
    wenn IstWand dann
 +
      Beenden
 +
    *wenn
 +
    Schritt
 +
    RechtsDrehen
 +
    MarkeSetzen
 +
  *wenn
 +
  *wenn
 +
*wiederhole
 +
</pre>
  
 
</popup>
 
</popup>
 
</div>
 
</div>
 
+
|width=20px|
[[Lösungsvorschlag Einseitige bedingte Anweisung2|Lösungsvorschlag]]
+
|width=300px |
 +
|}
  
 
==Übungsaufgaben==
 
==Übungsaufgaben==
Zeile 1.309: Zeile 1.447:
  
 
[[Lösungsvorschlag Karol Übungsaufgabe 9|Lösungsvorschlag]]
 
[[Lösungsvorschlag Karol Übungsaufgabe 9|Lösungsvorschlag]]
 +
 +
 +
 +
'''Aufgabe 10'''
 +
 +
Karol soll eine Pyramide in einer Welt mit maximaler Kantenlänge 20x20 bauen und mit Marken belegen.
 +
 +
[[Datei:Karol_A10.PNG]]
 +
 +
[[Lösungsvorschlag Karol Übungsaufgabe 10|Lösungsvorschlag]]
 +
 +
 +
 +
'''Aufgabe 11'''
 +
 +
Karol soll wie im Video dargestellt einen Kolben imitieren. Die Größe der Welt ist 4x4x10. In den Einstellungen soll Karol eine sehr geringe Ablaufverzögerung erhalten.
 +
 +
<div style="margin-left:100px; margin-top:30px; margin-bottom:30px">
 +
{{#ev:youtube|D0sn-j66Vd8}}
 +
</div>
 +
 +
[[Lösungsvorschlag Karol Übungsaufgabe 11|Lösungsvorschlag]]

Aktuelle Version vom 24. Mai 2019, 14:27 Uhr

Inhaltsverzeichnis

Das Programm

Robot Karol ist eine Programmierumgebung mit einer Programmiersprache, die zum Erlernen des Programmierens und zur Einführung in die Algorithmik in der Schule gedacht ist. Das Programm ist Freeware und kann über den Link Karol heruntergeladen werden.


Die Oberfläche

Die Programmoberfläche von Karol ist zweigeteilt: Auf der linken Seiten befindet sich der sogenannte Editor, in dem die Programme geschrieben werden. Auf der rechten Seite ist Karols Welt, in der das verfasste Programm ausgeführt werden kann.

Objekte

In Karos Welt gibt es einige Objekte, die von Karo verteilt und wieder eingesammelt werden können.


  • Ziegel
Karol kann Ziegel vor sich hinlegen. Sollte vor ihm bereits ein Ziegel liegen, wird der nächste Ziegel auf den anderen drauf gelegt.
Wenn Karol vor einem Ziegel steht und einen Schritt macht, steigt er auf den Ziegel. Allerdings kann er nicht über 2 Ziegel auf einmal steigen.
Das heißt um auf einen 2er Ziegelturm zu kommen, muss er über einen davorliegenden einzelnen Ziegelstein "klettern".
  • Marke
Marken werden direkt auf das Feld unter Karol gelegt. Sie dienen zur Orientierung und haben keinen Einfluss auf Karols
Bewegungsmöglichkeiten; er kann einfach darüber laufen. Im Gegensatz zu Ziegeln können nicht mehrere Marken übereinander gestapelt werden.
  • Quader
Quader versperren Karol den Weg. Er kann nicht über sie gehen. Außerdem lassen sie sich nicht stapeln.


ObjekteKarol.png

Die Bewegungmöglichkeiten von Karol

Die Bewegungsmöglichkeiten von Karol sind recht übersichtlich. Mit den angegebenen Anweisungen kann das entsprechende Verhalten gesteuert werden.


Verhalten Anweisung
ein Schritt vorwärts Schritt
eine Vierteldrehung nach links LinksDrehen
eine Vierteldrehung nach rechts RechtsDrehen
einen Ziegel vor sich hinlegen Hinlegen
einen Ziegel vor sich entfernen Aufheben
eine gelbe Marke unter sich legen MarkeSetzen
eine gelbe Marke unter sich entfernen MarkeLöschen


Karols Welt

Auf der rechten Seite der Karoloberfläche befindet sich Karols Welt. Durch Aufruf von Welt - Neue Welt kann die gewünschte Ausdehnung der neuen Welt festgelegt werden. Wenn die Ausgangsposition vom Standardstartpunkt (1,1) abweicht oder Hindernisse zur von Karol zu lösenden Welt gehören, dann empfiehlt es sich, die Welt über Welt - Welt speichern mit der Endung .kdw abzuspeichern. KarolsWelt.JPG


Erste Programme

Das Programm "Robot Karol" ermöglicht es uns, dem Roboter, der sich in seiner Welt bewegen und Aufgaben erfüllen kann, Anweisungen zu geben.

Durch eine Anweisung (z.B. "Schritt") sendet man eine Botschaft an ein Objekt (z.B. Karol), das darauf mit der zugehörigen Methode reagiert (z.B. Schritt() ).



Aufgabe
Karol soll eine U-Form abschreiten

Lösung

umgangssprachlich formuliert Karolprogramm
  • 2 mal vorwärts
  • Linksum
  • 2 mal vorwärts
  • Linksum
  • 2 mal vorwärts

Schritt
Schritt
LinksDrehen
Schritt
Schritt
LinksDrehen
Schritt
Schritt


Eine solche Folge von Anweisungen bezeichnet man als Algorithmus.

Ein Algorithmus ist eine endliche Folge aus eindeutigen und ausführbaren Anweisungen zur Lösung eines allgemeinen Problems.
Ein Programm ist ein Algorithmus, der in einer formalisierten Sprache abgefasst ist und maschinell ausgeführt werden kann.


Aufgaben:

1. Karol soll ein Rechteck ablaufen und am Ende wieder in der Ausgangsposition stehen.

2. Damit man besser erkennt, ob Karol auch ein „U“ durchläuft, soll er dabei Marken setzen. Es soll also eine „U-Form mit Markierungen“ gebildet werden.

3. Karol soll vier Ziegel in einer Reihe nebeneinander legen.

Selbstdefinierte Methoden

Die Fähigkeiten von Karol können durch neue, zusätzliche Methoden erweitert werden. Diese selbstdefinierten Anweisungen müssen vorher vom Programmierer festgelegt werden. Neue Methoden beginnen stets mit dem Wort Anweisung und dann mit dem Bezeichner der Methode. Es folgt eine Sequenz von Anweisungen, die beim Aufruf der Methode abgearbeitet werden. Die Festlegung der Methode endet mit dem Schlüsselwort *Anweisung.

Beispiel 1: Neue Methode Umdrehen

Anweisung Umdrehen
  LinksDrehen
  LinksDrehen
*Anweisung


Aufgabe: Karol soll einen Schritt rückwärts gehen. (Die Lösung greift nun auf die Anweisung Umdrehen zu.)

Anweisung Umdrehen 
  LinksDrehen 
  LinksDrehen 
*Anweisung 

Programm 
  Umdrehen 
  Schritt 
  Umdrehen 
*Programm


Aufgaben

1. Bringe Karol mittels einer selbstdefinierten Anweisung bei, einen Riesenschritt auf einmal zu vollführen, der so groß wie drei normale Schritte ist.

2. Schreibe ein Karol-Programm, das ihn dazu bringt immer drei Schritte vorwärts und zwei zurück zu gehen. Nutze dabei die Anweisungen Umdrehen, SchrittZurueck, Riesenschritt und SillyWalk (= 3 vor, 2 zurück).

3. Bringe Karol den Rösslsprung bei, wie ihn die Springerfigur beim Schach ausführt. Erstelle ein Programm, so dass Karol mehrere Rösslsprünge ausführt und nach jedem Sprung eine Marke setzt.

 Screenshot Roesselsprung.JPG


Parameter

Mit Hilfe eines Parameters oder Übergabewertes können wir Programme flexibler gestalten, ohne ganze Programmteile neu schreiben zu müssen. Beispielsweise können wir das Programm

Schritt
Schritt
Schritt
Hinlegen
Hinlegen
Hinlegen

kürzer schreiben als

Schritt(3)
Hinlegen(3)

Wir übergeben dabei in der Klammer hinter dem Methodenaufruf die Anzahl der Wiederholungen. Neben Schritt und Hinlegen kann man auch Aufheben mit einem Parameterwert verwenden.

Weiterhin ist es mit Robot Karol (ab Version 3.0) möglich, den Methoden Hinlegen und MarkeSetzen eine Farbe (rot, gelb, blau und grün) zu übergeben.
Beispiel:

Hinlegen(blau)
MarkeSetzen(grün)


Parameter können auch im Zusammenhang mit selbstdefinierten Anweisungen verwendet werden:

Anweisung Seite(X)
Schritt(X)
LinksDrehen
*Anweisung

Seite(5)
Seite(3)
Seite(5)
Seite(3)

Mit dieser Anweisung können wir Karol ein Rechteck beliebiger Größe bauen lassen, in diesem Fall ein Rechteck der Größe 3x5. Zu beachten ist, dass als Parameter in Anweisungen grundsätzlich X zu verwenden ist.


Aufgabe 1: Karol soll mit Hilfe von selbstdefinierten Anweisungen und Anweisungen mit Parameterwert eine Säulenhalle bauen.

Karol saeulenhalle.JPG


Aufgabe 2: Karol soll mit Hilfe einer selbstdefinierten Anweisung mit Parameterwert eine Treppe bauen.

Karol treppe.JPG

Wiederholung mit fester Anzahl

Problem: Karol soll vier Ziegel in einer Reihe hintereinander legen.
Erste Lösung durch sequentielles Anschreiben der Anweisungen:

Hinlegen
Schritt
Hinlegen
Schritt
Hinlegen
Schritt
Hinlegen
Schritt

Bei größerer Zahl von Wiederholungen erweist sich das Ganze als ungünstig. Bessere Lösung: Wiederholung mit fester Anzahl


Wiederholung mit fester Anzahl
Die Anweisungen im Wiederholungsteil werden nacheinander mehrfach ausgeführt (entsprechend der angegebenen Anzahl).
Sprache Karol:

wiederhole n mal 
   Anweisungen 
*wiederhole

Die günstigere Lösung für unsere Aufgabe sieht dann wie folgt aus:

wiederhole 4 mal
   hinlegen
   schritt
*wiederhole


Aufgaben

1. Karol soll mit Ziegeln ein Quadrat auslegen.

Screenshot Quadrat.JPG

2. Die bereits bekannte Aufgabe Karol soll vier Ziegel nebeneinander legen. soll mit einer Wiederholungsanweisung gelöst werden.

Screenshot ZiegelNebeneinander.JPG

3.In einer Welt der Größe 6x6 soll Karol mit Marken eine Diagonale erzeugen.

Screenshot Diagonale.JPG

4. In einer Welt der Größe 9x9 erzeugt Karol ein Kreuz aus Marken.

Screenshot kreuz.JPG


5. In einer Welt der Größe 11x11 soll Karol folgendes Muster erzeugen. Verwende dabei eine selbstdefinierte Anweisung und eine Wiederholungsanweisung.

KarolStufe.JPG

Geschachtelte Wiederholung

Problem: Karol soll einen Quadratrand auslegen.

Screenshot Quadratrand.JPG

Lösung

Der Quadratrand besteht aus vier Seiten (äußere Schleife). Jede Seite besteht wiederum aus drei Ziegeln (innere Schleife). Nach jeder Seite muss sich Karol links drehen.

Karol Quadratrand lsg.JPG


Aufgaben

1. Karol soll in einer Welt der Größe 9x9 eine hübsche Gartenmauer bauen.

Karol Gartenmauer.JPG

2. Die Aufgabe 1 im Kapitel "Parameter" (Säulenhalle) soll allein mit Wiederholungsanweisungen gelöst werden.


3. Karol soll eine Welt [8x8] vollständig mit Kacheln auslegen. Schreibe dazu ein Programm, das Anweisungen zur Lösung von Teilproblemen und geschachtelte Wiederholungen enthält. Überlege dir zuerst eine Strategie zur Lösung der Aufgabe, bei der du sie in solche Teilprobleme zerlegst.

Wiederholung mit Anfangsbedingung

Bestimmte Problemstellungen lassen sich mit den bisherigen Methoden und Kontrollstrukturen nicht zufrieden stellend bearbeiten. Die Lösung der Aufgabe „Gehe bis zur nächsten Wand“ hängt von der Startposition Karols ab. Um unabhängig von der Ausgangsstellung zu sein, muss Karol eine Methode kennen, die eine Anfrage, ob er noch weitergehen kann, mit WAHR oder FALSCH beantwortet. Der Aufruf derartiger Methoden wird mit „Bedingung“ umschrieben.


Karol hat auch Methoden, mit denen er auf eine Anfrage mit WAHR oder FALSCH antwortet. Der Aufruf einer Methode dieser Art heißt Bedingung.


Von Karol vorgegebene Bedingungen sind: IstWand, NichtIstWand, IstZiegel, NichtIstZiegel, IstMarke, NichtIstMarke, IstSüden, IstNorden, IstOsten, IstWesten.

Bei der Bedingung IstZiegel ist auch ein Parameterwert möglich, d.h. man kann z.B. eine Anweisung nur dann durchführen lassen, wenn zwei Ziegel vor Karol liegen (wenn istZiegel(2) dann Anweisung)


Problem: Karol soll, solange er nicht an eine Wand anstößt, vorwärts gehen.


Er muss den Vorgang „Schritt“ solange wiederholen, bis er auf die Frage NichtIstWand mit WAHR antwortet, da man die Anzahl der möglichen Schritte nicht im Voraus kennt. Sie ist von der Ausgangsposition Karols abhängig.


Lösung: Wiederholung mit Anfangsbedingung

Die Anweisungen im Wiederholungsteil werden so oft wiederholt, solange die Bedingung WAHR ergibt. Die Überprüfung der Bedingung erfolgt am Anfang jeder Wiederholung.

Sprache Karol:

wiederhole solange Bedingung
   Anweisungen
*wiederhole

Aufgaben

1. Karol soll in einer rechteckigen Welt von einer Ecke aus genau einmal um die Welt herumlaufen und seine Strecke dabei mit Ziegeln belegen.

2. Wie Aufgabe 1. Aber nun soll Karol an einem beliebigen Ort an der Wand starten.

3. Karol soll die bereits bekannt Aufgabe Kreuz aus Marken (siehe oben) so lösen, dass er das Kreuz in beliebigen quadratischen Welten mit ungerader Kantenlänge erzeugen kann.

Zweiseitige bedingte Anweisung

Das Programm für die Lösung der Aufgabe "Karol soll von einem beliebigen Punkt an der Wand aus einmal an der Wand entlang genau eine Runde laufen und dabei seine Ziegel hinlegen", lässt sich dadurch vereinfachen, dass wir ihn bei jedem Schritt entscheiden lassen, was er als nächstes tut:
Solange er nicht an der Wand anstößt macht er jeweils einen Schritt. Stößt er an der Wand an dreht er sich nach links. Der Vorteil ist, dass wir nicht mehr anzugeben brauchen, wie oft Karol sich drehen muss, bis er seine Runde absolviert hat.

Bedingte Anweisung (zweiseitig):
In Abhängigkeit davon, ob die Bedingung erfüllt wird oder nicht, werden die Anweisungen1 bzw. die Anweisungen2 ausgeführt.

Sprache Karol:

wenn Bedingung dann
   Anweisungen1
sonst
   Anweisungen2
*wenn


Aufgaben

1. Das Beispielprogramm "Karol soll von einem beliebigen Punkt an der Wand aus einmal an der Wand entlang genau eine Runde laufen und dabei seine Ziegel hinlegen" soll in ein Programm mit einer bedingten Anweisung umgewandelt und dadurch vereinfacht werden.


2. Wie Aufgabe 1, nur dass Karol von einem beliebigen Feld in der Welt startet und auch wieder an seinen Ausgangspunkt zurückkehrt.
a) Lösung ohne Verwendung der bedingten Anweisung.
b) Lösung unter Verwendung der bedingten Anweisung.

3.

a) Karol hat eine Reihe von Ziegelsteinen vor sich. Dort wo ein Stein liegt, soll er ihn wegnehmen, dort wo keiner liegt, soll er einen Stein hinlegen.
b) wie a), nur dass nun eine beliebige Zahl von Ziegeln übereinander liegen kann.
c) Nun soll Karol das Ganze 4 mal wiederholen, wobei er jeweils an der Wand entlang zurückgehen und zu seinem Ausgangspunkt zurückkehren soll.

Einseitige bedingte Anweisung

Aufgabe:
Karol soll eine lückenhafte Ziegelreihe auffüllen, bis er an der Wand ankommt. Vor jedem Schritt muss er nur dann einen Ziegel legen, wenn vor ihm keiner liegt. Falls bereits ein Ziegel vor ihm liegt, geschieht nichts.

Bedingte Anweisung (einseitig): Wenn die Bedingung WAHR ergibt, werden die Anweisungen ausgeführt.

Sprache Karol:

wenn Bedingung dann
   Anweisungen
*wenn

Lösung der obigen Aufgabe:

wiederhole solange nicht IstWand
   wenn nicht IstZiegel dann
      Hinlegen
   *wenn
   Schritt
*wiederhole

Aufgaben

1. In einer Welt (9x8) sind 15 Marken beliebig verteilt. Karol soll von einem beliebigen Startpunkt ausgehend, alle Marken mit Ziegelsteinen belegen und dabei keine Marke vergessen. Teste das Programm mit verschiedenen Startpunkten von Karol.


2. Karol soll von seinem üblichen Startpunkt eine Welt beliebiger Größe mit Marken kacheln und, wenn er damit fertig ist, das Programm mit dem Befehl beenden abbrechen. Es ist dazu eine Verschachtelung mehrerer bedingter Anweisungen nötig!

Übungsaufgaben

Aufgabe 1

In einer Welt soll Karol spiralförmig bis zum durch eine Marke gekennzeichneten Mittelpunkt laufen. Im Beispiel handelt es sich um eine Welt der Größe 13x12. Der Mittelpunkt befindet sich auf Punkt (7/7), wobei das linke obere Feld (1/1) sei. Grundsätzlich soll das Programm jedoch in allen vergleichbaren Welten laufen. Es ist bei der Aufgabe erforderlich in der 2D-Darstellung zu arbeiten.

Das Problem sollte wie gewohnt in Teilprobleme zerlegt werden, die dann nacheinander programmiert werden. In diesem Fall lässt sich die Aufgabe in vier Teilprobleme zerlegen: Es sind am Anfang und am Ende bestimmte Schritte zu erledigen, während die Spirale selbst in zwei Teilprobleme zerlegt werden kann.

Uebung Karol Schleife.PNG


Lösungsvorschlag


Aufgabe 2

Karol soll in einer beliebig großen Welt ein Schachbrett bauen.

SchachbrettÜ.jpg


Lösungsvorschlag


Aufgabe 3

In einer quadratischen Welt mit ungeradzahliger Seitenlänge soll Karol folgendes Muster erstellen:

Uebung Karol Raute.PNG

Lösungsvorschlag


Aufgabe 4


Karol ist unter die Ritter gegangen. Er soll auf der Mauer seiner Burg patrouillieren, ohne herunterzufallen. Dazu muss er bei jedem Schritt überprüfen, ob er vor einer Kante steht. Als weitere Sicherheitsmaßnahme vor Feinden baut er hinter sich die Treppe ab.

Uebung Karol Burgmauer.PNG

Lösungsvorschlag


Aufgabe 5

Karol soll in einer beliebig großen Welt mit gerader Länge und gerader Breite (Bild: 10x10) und 10 Ziegeln Höhe eine Zinnenmauer bauen.

Zinnen.PNG

Lösungsvorschlag


Aufgabe 6

Karol soll im Ziegelparcours um die Ziegel herumlaufen und am Schluss bis zur Wand.

Karol A6.PNG

Lösungsvorschlag


Aufgabe 7

Karol ist auf dem Volksfest und soll in einem Wettbewerb Bierkisten stapeln. Dazu sind auf einer Bahn in unregelmäßigen Abständen Marken verteilt. Karol soll nun bis zur anderen Wand laufen und auf jeder Marke 5 Kisten stapeln.

Karol A7.PNG

Lösungsvorschlag


Aufgabe 8

Karol soll einen leeren Brunnen mit Marken als Boden bauen.

Brunnen.PNG

Lösungsvorschlag


Aufgabe 9

Karol steht auf einem beliebigen Platz und mit beliebiger Blickrichtung in der oberen Hälfte seiner Welt. Er soll nun den Durchgang durch die Mauer finden und anschließend zur Wand laufen.

Karol A9.PNG

Lösungsvorschlag


Aufgabe 10

Karol soll eine Pyramide in einer Welt mit maximaler Kantenlänge 20x20 bauen und mit Marken belegen.

Karol A10.PNG

Lösungsvorschlag


Aufgabe 11

Karol soll wie im Video dargestellt einen Kolben imitieren. Die Größe der Welt ist 4x4x10. In den Einstellungen soll Karol eine sehr geringe Ablaufverzögerung erhalten.

Lösungsvorschlag
Von „http://cgd.zum.de/index.php?title=Programmieren_lernen_mit_Robot_Karol&oldid=5434